This project is read-only.
1

Closed

HTC Hero and Samsung Alias 2 Not Recognized As Mobile

description

I am getting IsMobileDevice returned as "false" for both an HTC Hero phone I am testing with as well as a Samsung Alias 2. For the Samsung, I am testing using a emulator from a desktop browser, but my customer is also not seeing the expected results even with the physical device. The user agents are listed below:
 
HTC Hero => Mozilla/5.0 (Linux; U; Android 1.5; en-us; HERO200 Build/CUPCAKE) AppleWebKit/528.5+ (KHTML, like Gecko) Version/3.1.2 Mobile Safari/525.20.1
Samsung Alias 2 (From my emulator) => SCH-U750L/1.0+NetFront/3.0.22.2.17+(GUI)+MMP/2.0
 
I am not able to get the user agent from the customer with the Alias 2 directly as they claim to have trouble navigating to a site that will display it to them.
 
If you could please state when you may be including these devices as mobile, that would be great.
Closed Mar 10, 2010 at 9:35 AM by aiburk
This issue is resolved in the latest release

comments

aiburk wrote Feb 5, 2010 at 9:47 AM

Hi,

Thanks for this.
We've created a work item to add support for the User Agent you provided for the HTC Hero. This will be part of a future release.
The User Agent you provided for the Samsung currently has isMobileDevice = true in our Mobile Device Browser File.

Thanks,
Aidan

wrote Mar 10, 2010 at 9:35 AM

ericberens wrote Jun 7, 2010 at 4:21 PM

The Sprint Hero User Agent changed after there latest 2.1 update....and IsMobileDevice now returns false.

Mozilla/5.0 (Linux; U; Android 2.1-update1; en-us; A6277 Build/ERE27) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17 Sprint APA6277KT

wrote Feb 14, 2013 at 8:36 PM

wrote May 16, 2013 at 10:22 AM