Workaround for .NET < 3.5SP1?

Jun 4, 2009 at 8:33 AM

I thought this was exactly what I needed until I tried on my dev environment - we are stuck at .NET 2.0

There is no option of installing 3.5SP1 because of workload and risk.

Is there a workaround to get this to work with .NET 2? Like a previous poster I am only interested in the Request.Browser.IsMobileDevice property.

Coordinator
Jun 5, 2009 at 5:19 PM
Edited Jun 5, 2009 at 5:21 PM

Hi albemuth,

The MDBF can actually run in .NET 2.0, but requires .NET Framework 2.0 Service Pack 2. If you're running Windows Server 2003 or Windows XP, you can install a standalone copy of .NET 2.0 SP2, but if you're using Server 2008+, you'll need to use the .NET 3.5 SP1 installer, which includes .NET 2.0 SP2. Note that even if you install .NET 3.5 SP1, you can still use .NET Framework 2.0.

Thanks for bringing up this issue, we’ve updated our requirements page to reflect this.

Jordan